Can't integrate Jira Cloud and Octopus

#1

I configured Octopus and Jira Connect App installed on Jira Cloud by following the guide.

The TEST button under Release Note Options works well.
But, when I press the TEST button under Jira Connect App Password, I get the error.

Failed to get authentication token from Jira Connect App.

Why is this?

Thanks.

(Frank Lin) #3

Hi aetos,

Sorry you’re experiencing problems setting this up.

I wonder if it’s to do with permissions. There was a similar ticket a few month back and the cause was
“i had the permissions to add the app i didn’t have the permissions to manage it.”.

Could you give that a try and let us know please.

Thank you
Frank

#5

I uninstalled the Octopus app from Jira Cloud, re-installed and reconfigured it with an account that has Jira administrator privileges, but still got the same error message.

#7

I tried integrating Octopus with Jira Cloud with an account that has Jira admin privileges, but without success.
Do I need to have Octopus Deploy administrator privileges to integrate Octopus and Jira?
Since I use Octopus Cloud, I don’t have Octopus Deploy administrator privileges.
Is this feature supported on Octopus Cloud?

#8

When I click the Save button on the ‘Octopus Deploy configuration’ page on Jira Cloud, the request to https://jiraconnectapp.octopus.com/octopus/setup returned 400 responses.