Jira integration still error 400

Hi all,

I’m facing issues when trying to integrate Octopus Cloud with Jira Cloud. As mentioned here:

I’m getting the same error 400 - Bad request when I try to setup app in Jira. Because of that, integraiton from octopus -> Jira doesn’t work either and I’m getting “Failed to get authentication token from Jira Connect App.”.

I found this: https://github.com/OctopusDeploy/Issues/issues/6516
but that solves that for Octopus on Premise.

Any solution for Octopus Cloud for this issue?

Hi @frantisek.pernicka,

Thanks for getting in touch, and welcome! I’m sorry to hear you’re hitting this issue. I had a look at that bug report you linked to, and it shouldn’t be specific to cloud or self-hosted instances of Octopus. The root cause looks to have been within the third party integration with Jira, and the patch to fix it was put in place only in the Connect App itself (v1.3.0 specifically). If you’re running a version of the Connect App prior to 1.3.0, does upgrading that fix this issue for you?

I hope this helps, and let me know how you go!

Best regards,

Kenny

Thanks for a quick feedback.

Unfortunately, I don’t understand to “ConnectApp 1.3.0”, in my Jira cloud instance, I can see only:

Is there any other plugin I should install?

Hi @frantisek.pernicka,

Thanks for following up! I had another look at this with a colleague of mine, and we’re wondering if it might be the same root cause of an issue we’ve seen recently regarding a change since our implementation. This might be a shot in the dark so please let me know how you go. :slight_smile:

This was regarding the fact that password doesn’t seem to work now against Jira cloud (gave us the same auth failure). Access Token worked fine, so I’m thinking this might be the missing piece.

Quoting Atlassian’s doc page: “Basic authentication uses an API token to authenticate the client. The token is generated from a user’s Atlassian Account, encoded, then added to the header for requests to the API.”

Quoting the section in the docs that I believe is vital here in the issue you’re facing (within step three of this linked doc section):

“The password should be an API Token, rather than an actual password. You can create an API token from an Atlassian account in the ‘Security’ area.”

Can you confirm if you’re using an API Token here?

I hope this helps get you going, and please let me know how you get on.

Best regards,

Kenny

Hello,

thanks for the explanation, here’re the config steps I’m doing:

  1. in Jira, installed octopus plugin

  2. run plugin and get this:

  3. Copy Jira connect password to Octopus settings:

  4. Click Test button -> getting an error

  5. When I enter my login name and API key in Release Notes Options - this part works fine and I’m authenticated.

The issue is within step two of https://octopus.com/docs/releases/issue-tracking/jira#connecting-jira-cloud-and-octopus

Hi @frantisek.pernicka,

Thanks for following up with that additional information. I’m still digging into this one, but for the time being can you tell me which version of Octopus you’re running? I’m wondering if you’re hitting the issue linked below where the extension being disabled returns a 400 error when testing, though this was resolved in 2019.13.0.

If you’re on pre-2019.13.0 does the workaround of setting this to Enabled fix this issue up? If you’re post-2019.13.0, do you by chance have any proxies or firewalls that Octopus has to go out through to get to Jira?

I hope this helps narrow down the cause of this issue, and I look forward to hearing back!

Best regards,

Kenny

Here is the version of Octopus Cloud:
image

Version of Jira Cloud is the latest.
Version of octopus Deploy for Jira Cloud is:

Since we use both Jira and Octopus in Cloud, I don’t think there should be any firewall/proxy issues as well as I don’t think I can update any of the components :frowning:

I’ve tried to setup with Enabled set to true, false but with no success, same error.

Hi @frantisek.pernicka,

Thanks for the update and additional information. I ran through a couple more attempts to reproduce this ensuring versions matched identically. The only way I’ve been able to reproduce this Failed to get authentication token from Jira Connect App error when testing in Octopus is when the Octopus Installation Id on the Jira side is incorrect. Just to rule it out, could you try re-copy/pasting the Octopus Installation Id into Jira, and once that saves try a new test?

I hope this helps, and let me know how you go!

Best regards,

Kenny