Package release notes variable not working in Release notes

cloud
usability
known
(Luca Mahler) #1

We’re having the same issue as described here: Octopus.Release.Package works in release notes but not in Variables

The mentioned topic has been closed but we’re running into the same problem.


All four packages contain release notes. We used your template as described here: https://octopus.com/docs/managing-releases/release-notes

After creating the release the generated release notes are empty.

Ocotpus version: 2019.13.1

(Paul Calvert) #2

Hi Luca,

Thanks for getting in touch!

If you head to Library > Build Information are the relevant build info packages listed there?
e.g.

And if you view the packages details within the release, do you see the linked build information there too?
e.g.

Regards,
Paul

(Luca Mahler) #3

Hi Paul

Thank you very much for reaching out so quickly.

Actually the Build information section under Library is empty as well as the accorind Build information of the release packages.

(Paul Calvert) #4

That sounds like your build server isn’t successfully pushing the build information through to Octopus in order for it to generate the release notes.

Which build system are you using and are you seeing any errors from the push build information step?

(ewin.hong) #6

hello,
i am experiencing the same concern here. on version 2020.13.6

My build information is populated.

image

the above screenshot from @paul.calvert is a shot of the old metadata feature.

(Paul Calvert) #7

Hi @ewin.hong,

As you have packages showing in the build information repository, your issue looks to be slightly different.
What do you have set as your release notes template within Project > Settings?

(ewin.hong) #8

This is not set.

I didnt know this existed until this moment.

mine is using commits instead of workitem, but its seems like the same issue.

i put the release notes directly on the release manually. havent figured out why teamcity isnt putting the release note in automated way yet.

(Luca Mahler) #9

But the contained packages already have Release Notes:

Are they required to be provided by the Build information somehow?

(Paul Calvert) #10

Hi @ewin.hong,

TeamCity sends across the build information/release notes metadata, but doesn’t tell Octopus how to display it. The release notes template is what tells Octopus how to display the metadata included in the build information package.
As long as the template is added, you should then start seeing the release notes automatically created.

(Luca Mahler) #11

Also, we just push an already packed package:

I don’t know how to extract the package ID and version out of that one step later when pushing the Build information.

(Paul Calvert) #12

Octopus doesn’t extract the release notes from inside the .npkg unfortunately, it needs to be sent via the build information step.

Is your package not packaged within Azure DevOps at all?

(Luca Mahler) #13

OK, thanks for the answer.

How can I set the Release notes within the DevOps Push Package Build Information to Octopus step? I only see package ID and version.

(Paul Calvert) #14

The build information being pushed should automatically gather the commits linked to the build itself and send that metadata through to Octopus.
There is more information on the process here: https://octopus.com/docs/packaging-applications/build-servers#build-information

Typically, the push build information step would be in the same pipeline as the build itself.

(ewin.hong) #15

i added the commit version from this page below and still get the blank release notes except the text to show.

I know it worked at one point recently:


(ewin.hong) #16

i noticed a slight difference between my working release and not.

No build information on left side even though I am not experiencing problem with the build info.

good one: api/Spaces-1/projects/Projects-4/releases/1.104.1 has a json response with build information

bad one: api/Spaces-1/projects/Projects-4/releases/1.106.0-DEV.506 has a json response with empty build information

even though: build information is populated:

(ewin.hong) #17

any update to this issue?

so i noticed that it appears to work for my master build but doesnt for my dev build.

(Paul Calvert) #18

Hi @ewin.hong,

If it is working for one build but not another, are there any differences in the configuration of the build steps for those branches?

(ewin.hong) #19

from teamcity perspective, my dev build is build chain while master is not. but investigating with verbose logging:

(ewin.hong) #20

my dev build.

going to wait for next master build to provide comparison

dev builds target my dev channel in octopus
master build target my release channel in octopus

version numbers differ based on dev or release channel. as previous screenshot show version number-dev.# or version number

this screenshot shows the create release step from teamcity.

i notice that in master, it uses the additional command line arguments. i think there was an update that provided channel in the teamcity plugin.

(ewin.hong) #21

is the command line argument of “–packageversion” different from this field in teamcity plugin: ?
image

im trying it out

that was the problem.

image

1 Like