Exclude JIRA when creating build information

I followed the post here to add build information to the package from teamcity. That step succeeded, but it failed to create the release:

[13:26:16] [Octopus Deploy] Creating release…
[13:26:17] [Octopus Deploy] There was a problem with your request.
[13:26:17] [Octopus Deploy]
[13:26:17] [Octopus Deploy] - Build Information could not be retrieved
[13:26:17] [Octopus Deploy] - Jira: Username/password not configured
[13:26:17] [Octopus Deploy]
[13:26:17] [Octopus Deploy] Error from Octopus Server (HTTP 400 BadRequest)

I was expecting to just get the commit messages from git. Is there a way to do this without JIRA integration?

Hi @nicholas.lydon,

Welcome to the Octopus forums!

Thanks for reaching out.

If you only want commit messages from GitHub, you do not need to have JIRA integration. If you want Work Items, then you need it.

Do you by chance have JIRA integrated within your Octopus configuration but not filled out? It looks like Octopus is expecting credentials and failing.

Please let me know what you think.

Thanks,
Jeremy

Hi @jeremy.miller, thanks for your reply.
That’s entirely possible. I was wondering why it just assumes that we’re using JIRA. Can you tell me where/how this configuration should be filled out please?

Hey,

You’re very welcome.

To get to the Jira configuration, follow the 3 clicks in my screenshot. Configuration Tab-> Settings-> Jira.

Please let me know how it goes.

Thanks,
Jeremy