Deploy automatically to environment not firing

We recently updated to the latest version of Octopus (2021.3 build 12313) from a previous 2021.3 build and our automatic environment deployments do not seem to be triggering any longer. I’ve attached the diagnostics as well as some screenshots of what we’re seeing in our support files.

The odd thing is log reporting the following:

Processing automatic lifecycle promotions... 
Environments eligible for automatic release deployment: None

It doesn’t seem to be able to find the automatic release deployment even though we have no changed anything.

I tried restarting the service as well as removing and re-adding the environment in the lifecycle, but get the same result.

Hey @rrosiek,

Thanks for reaching out on our community forum! I’m sorry that your release trigger is not working as expected. We’ll help you get it sorted out.

Can you tell me more about your trigger and how it is set up? When a new package is pushed to your internal feed, is it creating a release? If so, is it coming from Jenkins/TeamCity, etc.? Also, have you tried any manual releases since the upgrade? Sometimes, a manual release will get the trigger to start being recognized. In your inquiry, I see the screenshot from your log, but I don’t see any other attached files, were there other logs attached?

I am looking forward to hearing back from you.


Hi Ryan,

I just wanted to jump in quickly for Brent, as I strongly suspect the issue you’re reporting is one we’ve recently reproduced and raised a bug for (link below).

I believe this is currently being looked at by the devs. Unfortunately the workaround to this issue (assuming it’s the same as what you’re seeing) is to manually deploy. :frowning:

I hope that helps narrow it down at the very least!

Best regards,


@brent_kinney Sorry, I forgot to mention the release creation steps. We use the Octopus plugin in TeamCity to create the release from the package that is also pushed to Octopus. This all appears to be working fine. The automation step is the first environment when the release is created if that helps at all.

Thank you @Kenneth_Bates , that sounds like our exact issue. I’ll keep an eye on this bug and we’ll manually deploy for now.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.