Wrong package name

I have some serious problems with auto deploy octopus release via Team City.

I have a project in VS with a non-ascii character in the project name say


However in my project settings I have specified assembly name


When I compile my solution in get


But when its packed via octopack on team city the nuget package becomes


During deploy via TeamCity when running
Running command: octo.exe create-release --server …

it is not able to find the package. In my team city output i says
[14:48:33]Finding latest NuGet package for step: Deploy MyProjectAA
[14:48:33]Could not find any packages with ID ‘MyProject†’ in the feed …

So there are two problems here:

  1. octo.exe is not able to handle characters likee æøå (standard norwegian characters)
  2. Octopack packs to pacakge with project name as package name, not using the assembly name in project settings.

The second issue is the most serious one, and when that is solved we all have a work around for problem one.

Hi Pal,

Thanks for getting in touch! To start with I believe this limitation of Octopus should be removed to allow for those characters.
So I have created an issue in GitHub which can be tracked here: https://github.com/OctopusDeploy/Issues/issues/1252

As for a workaround meanwhile, if you create a basic NuSpec file for your project, and rename the ID tag within to be MyProjectAA Octopack will honor this and name the package after the ID tag in your NuSpec.
Here is some documentation about Using Octopack with NuSpec files.

Hope that helps!


I will rename my project for now, that seems to be the easiest temporary solution for me!