Why environment is disabled in release page?

usability
(Mwang) #1

Dear Support,

We have two environments for deployment and defined two lifecycles them. But I could not select one environment in release page. I could see both lifecycle. But I could not select them. Hope you could see my attached images.

Can you give me some suggestions? Thanks.

Regards,
Max

(Ziaul Islam) #3

Hi Max,

Thanks for getting in touch. There are a few options that you could explore:

You could look at your permissions to see if you are allowed to deploy to your environment - you can do this by looking at this user’s permissions in your web portal (under Configuration > Test Permissions and selecting the user) and confirming if this user has DeploymentCreate permission for this AzureSQLDB environment.

Secondly you can look at your lifecycle configuration to see if it’s set up to allow deployments to these environments without first deploying to AzureUAT. Feel free to send a screenshot of your lifecycle and I’ll be happy to have a look

Lastly I would look at your deployment targets, do you have any configured for the environment you want to deploy too.

I hope this helps, any further questions please feel free to reach out :slight_smile:

Kind regards
Ziaul

1 Like
(Mwang) #4

Hi Ziaul,

Thanks for your infomration.

  1. I checked my permission and I do have DeploymentCreate permission.

  2. My lifecycle is very simple. I could find AzureSQLDB in default lifecycle. I added DatabaseUpdateLifecycle just because of default one does not work, I tried to add a new one to have a look is there any difference;

  3. There is a one targe machine in AzaureSQLDB:
    image

Hope you could find something in my settings.

Thanks.

Regards,
Max

(Mwang) #5

Hi Ziaul,

I found another thing:

I have 2 targets in my AzureUAT envirment:

But I could not select these targets if I choose "Include specific deployment targets:

Regards,
Max

(Ziaul Islam) #7

Hi Max,

Thank you for the screenshots.
Sorry to see that the options above did not work for you.

Could you please confirm if the role the step(s) is scoped to has been given to the correct machines? This could be the reason why you can cannot deploy to it. The link below will allow you to check if you have configured everything correctly.

I hope this helps, any further questions please feel free to reach out :slight_smile:

kind regards,
Ziaul

(Mwang) #8

Hi Ziaul,

I checked settings and it is right value. Please check:

We only have a one target role which is “Web”.

And this role includes all targets:

Regards,
Max