("Web Management Service"), but could not verify the server's certificate


I have read the workaround about this issue
in Azure we use: ASE and Isolated webapp
Octopus : we using : “Deploy an Azure Web App” task.

we get:
A certificate mismatch occurred. We have had reports previously of Azure using incorrect certificates for some Web App SCM sites, which seem to related to a known issue, a possible fix is documented in https://g.octopushq.com/CertificateMismatch

do We have to use SSL on the webapp?
do we have to use genuine certificate or self sign?
what is the best practice?


Thanks for getting in touch and I’m sorry for the delay in getting back to you on this one. I’m sorry to hear you are seeing issues while deploying to an Azure Web App that exists in an isolated ASE when Octopus can’t verify the servers’ certificate.

The support request here seems to be quite similar to yours. From an Octopus point of view it appears we can’t customise settings to surpress SSL issues or use HTTP so in this case we must use a valid SSL certificate.

I believe the only way around this issue is to ensure that the kudu portal (SCM) is presenting a valid SSL certificate here. I’m interested to know if you were able to perform the steps in the Microsoft certificate mismatch solution which you have linked us?

Kind regards,