Web Config Transform Not Completed

I have a Web.config file as well as a Web.Development.config file, but when I deploy to Environment Development, the transform is not applied and my Web.config sections have not been updated as expected. Not sure what I am doing wrong.

Hey kphelan,

Have you set your Web.Development.config file Build Action as Content so that it’s included in the package being used by Octopus?

Yes, build action is set as content. In fact every environment config file ends up in the package and deployed, but the transform just doesn’t happen.

Hey kphelan, I was having the same issue as you. I had “XML transformation” check box checked on the step that was deploying my website but the transformations were not happening even though the transforms were in the package. After checking the “XML variables” check box as well, it started to perform the transformations. It doesn’t seem like the correct solution but it got my web.config transforming

Thanks bosko, I’ll give it a shot. I ended up adding all the appsetting and connection string variables and checking that. It works for now, but I will need to add some other sections that will need to be replaced as well so I’ll give your suggestion a shot and remove some of the variables I added and see if I can get it working.

Well, that didn’t seem to solve my issue. I removed one of the variables and tried to create and deploy a new release. When I checked the config file, it had not been updated other than the variables that were still there for the project. Any other ideas?

Hitting a similar issue:

  • config transformations do happen (looking at the deployment logs)
  • publishing through FTP to WAWS, but all config files get deployed (in a non-transformed state)

@bosko - that fixed it for me. Like you say though, it doesn’t seem right that you have to enable it.

hi - any further info/fix regarding this issue? thanks

@bosko - fixed it for me as well. Seems like a bug.