Versioning a .dacpac file and positioning a Deploy.ps1 file

Good morning,

I’m hoping to use Octopack / Octopus to deploy a SSDT project as a .dacpac file.

At the moment I have two issues.

Firstly, when I create the .dacpac. (via a .nuspec file) Octopack seems to ignore my tag. I’ve also tried to set the version via msbuild flag and this seems to be ignored too, the package always come out as :frowning:
If it’s any help, my other projects work fine with the version flag (taken from the AssemblyInfo.cs.

The second issue is with my Deploy.ps1 script, I’ve tried to include this in my nuget package via the .nuspec file but it always seems to come out in a sub folder and then Octopus tells me:
The script file “MyApplication\Deploy.ps1” contained within the package will not be executed because it is contained within a child folder. As of Octopus Deploy 2.4, scripts in sub folders will not be executed.

I’ve included a screenshot of how the inside of the nuget package looks (the deploy.ps1 script seems to be put inside the ‘MyApplication’ folder)

Could you let me know how to set the nuspec collection to build a package which Octopus would expect?

I’ve included my current .nuspec as it stands, I’ve spent a day or so messing with the paths just to get the package to build ok! it feels like I’m close, but I just need to sort these last two issues out to complete the full app deployment.

Any thoughts / help would be greatly appreciated.

Database.nuspec (753 Bytes)



Thanks for getting in touch! Before we jump into the versioning troubleshooting, could you please send us a full build log to get a better glimpse of your build process?

As for the Deploy.ps1 file, instead of adding it from your nuspec file, you could add it to the root for your solution as shown on this link