Unexpected error occurred: resource not found

unknown
server
reliability
(Conor Boyd) #1

Looks like an upgrade issue as these projects have been working fine for months, but we recently upgraded to Octopus v2020.1.4.

We have Tomcat WAR files hosted in Artifactory with appropriate feeds set up in Octopus.
The feedname is specified in a Project Variable:

This Variable is used to set the Package Feed value in the Deploy a Package step:


When we visit the Deployments > Process page, we receive an error banner at the top of the page saying: “An unexpected error occurred in Octopus v2020.1.4: The resource ‘#{PackageFeed}’ was not found.”

I don’t think it actually causes any problems, as it is still possible to create releases and have the packages successfully located in the feed, but I don’t believe this error message should be displayed when it wasn’t before the upgrade, and it is causing confusion for my users.

Please advise.

Cheers,

Conor

(Kenneth Bates) #3

Hi Conor,

Thanks for getting in touch! That certainly is a confusing (and annoying!) error. I’m sorry for the inconvenience this has caused you. I’ve been able to reproduce this as well so I’ve raised a bug report to address this, and you can follow the progress of that at the following link.

I appreciate you bringing this one to our attention. If you have any questions or concerns going forward, please don’t hesitate to reach out. :slight_smile:

Best regards,

Kenny

(Conor Boyd) #4

Thanks Kenny, I’ve subscribed to the issue.

(Kenneth Bates) #5

Hi Conor,

You’re very welcome, and thanks for keeping in touch. If you have any questions in the future, please don’t hesitate to reach out anytime.

Best regards,

Kenny