Unavailable targets create continuous flow of requests in web interface

Hi Octopus Support,

The web interface continuously keeps requesting /api/tagsets/all when a deployment target is not present anymore in the network. Even when it is “unavailable” or “disabled”, these requests stream out of the browser.

How did I get to this? I copied an entire Octopus setup from a previous installation on a different network and -of course- copied the deployment targets along with it. Then I opened up the browser to inspect the setup. The targets were marked as “unavailable”, which is correct.
But in Internet Explorer it is not possible to delete these targets as the browser keeps requesting /api/tagsets/all requests. That locks the web interface. In Chrome it does the same but Chrome still allows you to work with the web interface while it also continuously keeps sending requests.
Switching off the deployment target is also not possible in IE, as that happens in the same web page as deleting the target. In Chrome, all actions are still possible despite the flow of requests in the background.

The /api/tagsets/all requests are responded to by 304s, btw. That may be the cause of the problem.

Details of these requests are below. I bet this is an oversight in the javascript code. Can you please fix it?


The requests are:
URI: https://my.octopus.server/api/tagsets/all

GET /api/tagsets/all HTTP/1.1
Host: my.octopus.server
Connection: keep-alive
Accept: application/json
X-Octopus-Data-Version: ******************=
X-Octopus-Authorization-Hash: ************************=
X-Octopus-User-Agent: OctopusClient-js/2018.10.5
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Safari/537.36
Accept-Encoding: gzip, deflate, br
Accept-Language: en-US,en;q=0.9,nl;q=0.8
Cookie: OctopusIdentificationToken_***=; Octopus-Csrf-Token_

Response headers:
HTTP/1.1 304 Not Modified
Cache-Control: private no-cache, no-store
Content-Length: 0
Content-Type: text/html
Expires: Wed, 27 Mar 2019 10:18:35 GMT
Server: Octopus Deploy/ Microsoft-HTTPAPI/2.0
X-UA-Compatible: IE=edge
Content-Security-Policy: default-src ‘none’; connect-src ‘self’; font-src ‘self’; img-src data: https://www.gravatar.com ‘self’; script-src eval: inline: ‘self’ ‘unsafe-eval’ ‘unsafe-inline’; style-src inline: ‘self’ ‘unsafe-inline’; worker-src ‘self’; block-all-mixed-content; sandbox allow-same-origin allow-scripts allow-forms allow-popups allow-modals;
Octopus-Node: name=*********; version=2018.10.5
Referrer-Policy: no-referrer
X-Content-Type-Options: nosniff
X-Frame-Options: DENY
X-XSS-Protection: 1; mode=block
Server-Timing: total;dur=1
Date: Thu, 28 Mar 2019 10:18:34 GMT


Hi Eelko,

Thanks for reporting this to us. I’ve been able to reproduce the problem and have raised an issue. I will look into a fix in the coming days.

As a work around, if you expand the Associated Tenants section, the requests will stop. I am unsure why at this stage. However this probably won’t work in IE if it’s frozen.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.