Unable to run octo cli

Somewhat recently my octo cli stopped working. I’m running on Ubuntu 20.04. Pretty sure it stopped working with one of the latest releases targetting .net 6. I’m installing it with dotnet tool install --global Octopus.DotNet.Cli --version 9.0.0

When I run dotnet octo I get

It was not possible to find any compatible framework version
The framework 'Microsoft.NETCore.App', version '6.0.0' was not found.
  - The following frameworks were found:
      3.1.6 at [/usr/local/share/dotnet/shared/Microsoft.NETCore.App]

You can resolve the problem by installing the specified framework and/or SDK.

The specified framework can be found at:
  - https://aka.ms/dotnet-core-applaunch?framework=Microsoft.NETCore.App&framework_version=6.0.0&arch=x64&rid=ubuntu.20.04-x64

when I run dotnet --list-runtimes I get

Microsoft.AspNetCore.App 3.1.25 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 5.0.17 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 6.0.5 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.NETCore.App 3.1.25 [/usr/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 5.0.17 [/usr/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 6.0.5 [/usr/share/dotnet/shared/Microsoft.NETCore.App]

I notice the output from octo references a runtime that doesn’t show in the output list when I view the runtime list. Seems like path expectations are amiss. Thanks for your help.

Hi @mfrank1
Welcome to the Octopus forums!

Thanks for reaching out with this issue - I haven’t seen this particular error before.

I have a feeling there might be a hidden bug in this latest version and I will run this by the Dev team for them to have a look at.

In the meantime there may be some workarounds you could try to get you back up and running:

  • you can try uninstalling this ver 9 and re-install the version you had previously that worked for you
  • you can also try using the self-contained executable which works independently of the installed .NET runtimes. You can grab it here: Download Octopus CLI - Octopus Deploy
  • at a pinch you could try soft linking from the framework version dotnet octo found to the one the --list-runtimes found ([/usr/share/dotnet/shared/Microsoft.NETCore.App]), but that is also a bit of a kludge.

In the meantime I will check in with the Dev crew and see if there is known issue. I will get back to you as soon as I get their feedback.

Kind Regards,

Hi @mfrank1
I checked in with the Dev team on this issue and they did some tests for me earlier. From their assessment, ver 9 does work well with UBUNTU 20.04 and it was specifically built for .NET 3.1.0 and higher and .NET 6.0 and above.

So it does seem like your .NET environment might be a little confused and this could be causing the issue. Possibly removing the 3.1.6 environment might get you past the error and then scanning the other runtimes. A little experimentation with that might fix it for you as well as standardising on the /usr/share /dotnet/shared/ path structure.

Let us know if you need more help.

Kind Regards,

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.