Unable to push package to Octopus built-in feed

Hello,
I was building tabular model project and Unable to push package to Octopus built in feed.
[error]Failed to push package. The process ‘D:\xxxx\xxxx_work_tool\octo\7.4.3663\x64\octo.cmd’ failed with exit code 4294967295

Good afternoon @shivadeveloper878,

Thank you for contacting Octopus Support and sorry to hear you are having issues with one of your package pushes to Octopus. There is another forum post similar to this where a user was getting the same error as you.

I am wondering if you can check over that forum post and see if your error logs are showing similar results (ie are the logs telling you the package file is not found).

If so there may be some suggestions in that post you can try. Let me know if you are getting similar errors and if you are able to look at your build logs to see if the package has been pushed to Octopus and it is in the correct location.

I look forward to hearing from you,

Kind Regards,

Clare

Clare,

I have tried but still having the same issue. It’s generating package but it couldn’t find the path when it comes to push package.

Thanks

Hey @shivadeveloper878,

The exit code 4294967295 shows this message:
A connection attempt failed because the connected party did not properly respond after a period of time, or an established connection failed because the connected host failed to respond

I’ve got a few questions for you that should help narrow down the cause:

  • Can you send over the push command you used?
  • Are you pushing to an Octopus cloud instance or on-premise? If on-premise, what version are you using?
  • Can you check that your firewall/anti-virus where the command is run is allowing outbound access to the Octopus server and is not being blocked?

I am looking forward to hearing back from you.

Best,
Brent

Hey Brent,

The previous application configured through PowerShell. They are working fine. So there is no issue of firewall or antivirus. I’m using octopus on prem v2022.2. As I’m new to this I was configuring through octopus task. I’m using package octopus task and push packages to Octopus.
Test


Hi @shivadeveloper878,

I’m just stepping in for Clare and Brent as they’re offline with the US and UK support teams.

To give us a little more insight to what’s going on with this process, would you be happy to share the Build Solution step logs with us? You can upload your logs to this secure upload link using your current email address.

We look forward to hearing back!

Kind regards,
Lauren

Hey Lauren

Thanks for the response. uploaded the log file.

1 Like

Hi @shivadeveloper878

I believe TFS is not including the version numbers and extension when it tries to upload your package.
I don’t know exactly how you have your TFS build process, however you should be including the package version within the push command.

Package file not found: D:\agents\XXXXX.BuildAgent03\_work\18\s\test

The actual package file is: D:\agents\XXXXX.BuildAgent03_work\18\s\Test.2022.9.11.223956.nupkg

Please, let me know how that goes.

Regards,

Hey Dane,
I was using below tasks to package and push to Octopus.


As per the task if leave it blank in versioning, by default it is adding date and buildid to the package.

In push package task what other variables I need to provide along with the package name to pick up package in the package field. Ex: I have provided Packagename.$(Date).$(build.buildId). But getting error has wrong format.

Hey @shivadeveloper878,

You’d need to fill in the Package version line on your Package Application for Octopus step. Then in your push step you’d have the same version info. Your steps should look similar to the ones listed in this guide. These images should help:

Let us know if you have any other questions.

Best,

2 Likes