Unable to manage rules version on channels


(Fernando) #1

Hi,

We have updated to version v2018.9.0 and we found a stopper problem when managing the rules version of a channel. In one of our projects we have multiple nuget package deployment and we added different rules for some package. The problem is that even though the text said is for one step, inside there are all the steps of all the rules in the channel. For instance:

This is what we get when we enter in our channel

This happens when we expand one of the options

we tried also with a new channel and when we add a step on a rule, new rules will inherit that step too. Also its impossible to delete a step and if u tried, they multiply

Best regards


(Jon Henning) #3

Same problem here. This is a showstopper that is not allowing us to use this version (2018.9.1)
To put it simply, with this version you are UNABLE TO MAKE MORE THAN ON VERSION RULE ON A CHANNEL).


(Michael Richardson) #5

Fernando and Jon,

We sincerely apologize. This was absolutely a bug that was introduced in 2018.9.0.

We have committed a resolution for that will be released today in 2018.9.2.

Again, we are terribly sorry for the inconvenience. If there’s anything else we can do to help please don’t hesitate to reach out.

Regards,
Michael


Unable to make more than one version rule on channel (2018.9.1) - packages duplicate
(Jon Henning) #6

Thank you for fixing this as quickly as you did. Much appreciated!


(Fernando) #7

Thank you so much! :smile:


(Daniel Fischer) #8