Unable to log in to a new deployment

I’m trying to set up a new octopus server to test the upgrade paths from 3.0 to 3.2, but I can’t seem to log in with the new administrator account I created.

I’ve tried setting up an instance with both a clean, empty database and a restored backup of our 3.0 database, but each time when I try and log in with the new administrator account defined in the installer I get:

You must be logged in to perform this action. Please provide a valid API key or log in again.

If I enable Guest access through the Octopus Manager and try to “sign in as guest” I get the same error message.

There doesn’t appear to be anything particularly useful in the logs.


OctopusServer.txt (6 KB)


Thanks for reaching out. If you reset the admin password as shown on the “Resetting administrator passwords” section of this doc, can you login as admin? http://docs.octopusdeploy.com/display/OD/Resetting+passwords

Are you running more than 1 Octopus Server instance on that server?



Hi Dalmiro,

Sadly I get the same message - “you must be logged in to perform this action”.

No, I’d deliberately installed this on a new machine to test this out - however it’s a Windows 8.1 workstation talking to a local SQL Server instance rather than a Windows server. I’ll try it on a new VM in a little while.



Hi Ben,

We do not support running Octopus in desktop versions of windows. Octopus is tested and developed for Server versions of windows.

Please make sure that this new VM is a Windows Server.



Apologies, installing on a server seems to have resolved the login problem.


Hi Ben,

No need to apologize! Glad to hear its working for you now.