Unable to feed the package to own repository

Hi All,

I am facing issue while feeding the package to my own repository.
I have created package using Octo.exe and tried to feed the package to Octopus repository but it is showing an issue.

Created package using Octo.exe as below
Octo.exe pack --basePath=[Directory Location example: My published_website dir] --id=TOH --version=2014.11.11.0223-TOHRelease --outFolder=E:\Octopus\NuGetPackages /Verbosity
Octopus Deploy Command Line Tool, version
Packing TOH version 2014.11.11.0223-TOHRelease…
Saving TOH.2014.11.11.0223-TOHRelease.nupkg to E:\Octopus\NuGetPackages…

Tried to feed the package to Octopus repository.
NuGet.exe push E:\Octopus\NuGetPackages\TOH.2014.11.11.0223-TOHRelease.nupkg -ApiKey [My Octopus API Key] -Source http://something.com/nuget/packages/
Pushing TOH 2014.11.11.0223-TOHRelease to http://something.com/nuget/packages/
Please provide credentials for: http://something.com/nuget/packages/

UserName: Password:

Please help to solve this issue.
I am using Latest version of NuGet.exe

Hi Ganesh,

Thx for reaching us! That error shows up when an incorrect value is passed as an API Key. Please double check your API key and make sure there’s no extra or missing characters.


Hi Dalmiro,

Yes. You are correct. I was passing the wrong API key. I have provided the correct API key and i can able to feed the package to octopus deploy.


Hi Ganu,

Glad to hear!