Unable to Create Custom Script

modelling

(carlton@keyloop.co.uk) #1

Hello, since upgrading to 2018 I have been experiencing problems creating Custom Step Templates. Each time try to create a Custom Step Template I get the error:

There was a problem with your request
Please provide the script body to run.

I would normally just add some script to the body and save. However, I’m importing projects and therefore I really don’t want to have to insert some text to create the Custom Step Template.

I read that this was a bug in previous versions but was fixed with version 3.2.9

https://help.octopusdeploy.com/discussions/problems/43315-unable-to-use-just-an-octopus-variable-in-script

Also, this wasn’t happening before the current version 2018.3.1

Can someone please let me know if there is a fix for this?

Cheers

Carlton


(Reece) #3

Hi Carlton,

Thanks for getting in touch,

I’m sorry to hear you are experiencing inconvinience from this behavior,

I might be misunderstanding your concern, though it sounds like your importing Projects and are required to setup the pre-requisite Step Templates in order for the import to be succesful.

I’ve had a look at this behavior using a 3.x version and I’m still prevented from saving the template without specifying some text or blank characters in the script body before I can save it.

Can I ask which version of Octopus you were using at the time where this wasn’t a pre-requisite on the save of the Custom Step Template?

I look forward to hearing back from you :slight_smile:

Kind Regards,

Reece


(carlton@keyloop.co.uk) #4

Hi Reece,

Thanks for reaching out. I was using the version one below 2018.3 … not sure of the exact version number

Cheers


(system) #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.