Tentacle upgrade to 7.0.1 fails

Hi.

After upgrading to latest Octopus Server we are offered Tentacle upgrades for our polling tentacles.

However all upgrades seem to fail. Can anyone help as to the reason? I have added the tentacle upgrade logs.

UpgradeLog-20230905183634-0f249.log (893 Bytes)
UpgradeLog-MsiExec-0d35baf8-7490-4e63-85dd-65e384c544ce.txt (6.8 KB)

Hi @kbl_sg,

Thank you for contacting Octopus Support. Iā€™m sorry to hear you are running into this issue.

Can you confirm your current Octopus Server version?

Let me know at your earliest convenience.

Best Regards,
Donny

I just upgraded to Version 2023.3 (Build 12815).

Hi @kbl_sg,

Thank you for getting back to me.

I was able to reproduce this behavior in my local test instance. As a result, I have created this GitHub issue which you may subscribe to here. As a workaround, simply delete or rename the TentacleBundle folder on your Octopus Server.

Let me know if the workaround allows you to upgrade your Tentacles as expected once you get a chance to try.

Best Regards,
Donny

Hi @donny.bell .

I can confirm that the workaround allows me to upgrade the tentacles. Thank you.

1 Like