Tentacle problem after upgrading to

I installed Octopus Server and ran “Upgrade all” from the Environments page to upgrade my tentacles. Several of my tentacles upgraded successfully, but several of them did not. I reran the proces with no success.

I then ran the installer program on the servers in my environments that had failures. After the install/upgrade completed, I received the following error:

Could not start Octopus tools: Could not load file or assembly ‘System.Core, Version=, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes’ or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)

I tried uninstalling my tentacle and reinstalling. I also tried restarting. I don’t see anything in the event log. No luck. Any ideas?

Stack trace information from the Octopus server:

2013-05-08 19:24:59 ERROR One or more errors occurred. Octopus.Shared.Activities.ActivityFailedException: One or more Tentacles were not able to be upgraded. Please see the output log for details.

Server stack trace:
at Octopus.Server.Tasks.Upgrades.UpgradeControllerActivity.DumpResults(IList`1 results) in c:\w\e6923628be6eaf72\source\Octopus.Server\Tasks\Upgrades\UpgradeControllerActivity.cs:line 90
at Octopus.Server.Tasks.Upgrades.UpgradeControllerActivity.d__a.MoveNext() in c:\w\e6923628be6eaf72\source\Octopus.Server\Tasks\Upgrades\UpgradeControllerActivity.cs:line 55

Exception rethrown at [0]:
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccess(Task task)
at Octopus.Shared.Activities.ActivityRuntime.d__5.MoveNext() in c:\w\e6923628be6eaf72\source\Octopus.Shared\Activities\ActivityRuntime.cs:line 56

Hi Nick,

Thanks for getting in touch, you will need to either:

  1. Roll back the Octopus/Tentacle, or
  2. Install this hotfix: http://support.microsoft.com/kb/2468871

This is an issue to do with portable class library support in the .NET


Paul Stovell
Octopus Deploy
W: octopusdeploy.com | T: @octopusdeploy http://twitter.com/octopusdeploy

That worked! Thank you so much! I love Octopus!

From: Paul Stovell [mailto:tender2+de44aafc1c93726419c645ff8779f5d10e242cdf7@tenderapp.com]
Sent: Wednesday, May 08, 2013 7:56 PM
To: Nick Bialaszewski
Subject: Re: Tentacle problem after upgrading to [Problems #7409]