TeamCity not publishing to Octopus NuGet repo

I’ve setup a simple project on our development TeamCity server to test out Octopus and have hit a problem. I’ve added OctoPack to the relevant projects in the solution. The “Run OctoPack” option is checked. I’ve also modified the existing build step to include the following parameters:


OctoNuGet resolves to the same machine as TeamCity is running on, http://localhost:81/nuget/packages

The NuGet repo seems to work fine, I can test it and don’t get any errors. But this project, when I run it via TeamCity, no errors are reported, nothing bad in the TC logs, but also no package it pushed to the Octopus repo. I check the directory, empty. It’s not permissions, as I have them wide open right now.

Without any blatant errors, not sure what to do with this.


Hi Dean,

Thanks for reporting this. Is there any output from OctoPack in the TeamCity build log? Do any NuGet packages appear in the ‘Artifacts’ collection of the build in TeamCity?

If you can attach the full build log from TeamCity I should be able to work out what is going on.

Thanks again and hope to help,


Hey Paul,

No NuGet packages as artifacts no. There is output from OctoPack. I have attached the full build log from the last build, thanks!


Services_Trov.Service.Discovery.Email_1.0.0.18.log (81 KB)

Hi Dean,

It looks like the package has been pushed successfully, so the question is why isn’t it showing up in Octopus.

If you remote desktop to your Octopus server and navigate to:


Do you see any package files?


They are all there. Not sure what to make of that! It should work right?

EDIT: Scratch this thread. It’s working now! I’m not sure what I did wrong (or how I fixed it), but it’s working now! Thanks Paul!


Great to hear, thanks for the follow-up Dean.