Issue: Windows/Chrome

Just ran into a weird one and I can’t decide if this is an issue with Chrome or Octopus… It is not a large issue though since there is an obvious workaround.

Octopus: v 3.3.14
Client: Windows 7 Professional, SP1; Chrome 51.0.2704.63 m (also happened in v. 50.0.1226.x)

When attempting to sign in with valid credentials, if I leave the “Remember me on this computer” checkbox unchecked, I get the following error message (see attached screenshot as well):

You must be logged in to perform this action. Please provide a valid API key or log in again.

If I check the “remember me” checkbox, the sign-in process works and I am taken to the dashboard.

I have tried the same process in Internet Explorer (v 11) and the sign-in works regardless of the value of the “remember me” checkbox.

Regardless, the workaround is simple enough - just check the box and log in.


Hi Raleigh,

Thanks for reaching out.

And odd one indeed. I use chrome without the box checked every day and it just works. Have you tried clearing every cookie/cache from your browser? Is this happening to more users in your team? It totally looks like a client-side thing, so It wouldn’t surprise me if its only happening to you.


Yeah - it is pretty consistent across my development team. One of my devs actually noticed it first and came to me because he couldn’t get logged in. I figured it was something with his browser because I could still log in. We’ve all cleared caches, etc. and not seen any change in the behavior. Then I finally noticed that he wasn’t checking the box and I normally do. I tried it without the box and got the same behavior.

Anyway - we’re able to log in fine as long as we check the box, so no big deal. Hopefully at least if someone ends up having the same issue they’ll run across this and it will help.


Can you see any Javascript errors in the developer console when trying to log without the box checked?