Several issues since upgrading to v3.2.1

We’ve upgraded to v3.2.1 from v3.1.3 and that process went well. There are some things that I’ve noticed that seem a little off. I’ll just list them:

1.) In the Octopus Manager, in the proxy settings, it will not allow me to save the following setting: “Use the proxy server configured in Internet Explorer”. The configuration wizard appears to go through the motions of applying the settings and restarting the service. When I go back into the Octopus Manager the setting is set back to what it was before - “Use the proxy server configured in Internet Explorer, with custom credentials”

2.) Octopus incorrectly claims Calamari is not up to date in 3.2

3.) When developers try to scope a variable to an environment they do not have access to, they get the expected permission denied error. If they delete that variable and try to add another, they still get the error. They have to leave the project and come back to add the variables. Is this the expected behavior?

4.) When using the “Deploy an Azure Web App” step all machines in the target environment are listed in the task log.

Thanks for upgrading and adding your comments.

  1. I have indeed reproduced this and added GH Issue#2130 to track its progress.
  2. As indicated in your message this is a known issue that will be worked on.
  3. Also reproduced and added GH issue#2131
  4. We have seen this issue before but didn’t yet seem to have a ticket on it. I have added GH Issue#2132 to make sure it gets actioned.

Thanks again for your bug reports. Its feedback like that which helps to make Octopus Deploy better with each build.

Thanks for your quick response, Rob!