Set the "Enable 32-Bit Applications" property of an application pool

support

(mattias.geigant) #1

Can we configure the Enable 32-Bit Applications property of an IIS application pool from Octopus Deploy?


(Daniel Fischer) #3

Hi @mattias.geigant,

Thanks for getting in touch! Currently Octopus does not have the ability to set this option for you. Currently this can only be achieved with a custom PowerShell script as you mention.

We may look into supporting something like this in the future but at the moment a custom script is your only way.

Let me know if you have any further thoughts or questions here. :slight_smile:

Best regards,
Daniel


(mattias.geigant) #4

Hi @Daniel_Fischer,

Thanks for your reply! What would be a good way to set this property from a PowerShell script?

Spending some quality time with Google, I found a post of mine :open_mouth: from 2014 where I suggested this:

$appcmd = “$env:windir\system32\inetsrv\appcmd.exe set apppool /apppool.name:MyAppPool /enable32BitAppOnWin64:true”

Invoke-Expression $appcmd

Do you have a better solution? Are there any problems running a script in elevated mode from Octopus?


(Daniel Fischer) #5

Hi @mattias.geigant,

Thanks for the update! I think I also saw that example, however, I have not tried it yet.

Octopus executes any PowerShell scripts through the account running the Tentacle service. The Local System account is the default Tentacle account, which runs with elevated permissions. If you are not using the Local System account, you will need to make sure the selected account has the appropriate permissions.

As for how you can implement this script, there are multiple options. The most simple option is to use a standalone script step or a custom deployment script inside your package step.

Let me know if you have any more questions. :slight_smile:

Best regards,
Daniel


(mattias.geigant) #6

HI @Daniel_Fischer,

Thanks for the help. Setting up a standalone script step to run the PowerShell script worked like a charm. :slightly_smiling_face:


(Daniel Fischer) #7

Hi @mattias.geigant,

Thanks for the update! Please feel free to get in touch at any time. :slight_smile:

Best regards,
Daniel


(system) #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.