Serialization error on deploy to Azure

Retrying the sync because a socket error (10054) occurred.   
Retrying operation 'Serialization' on object MSDeploy.contentPath (sourcePath). Attempt 12 of 25.

We get this error when we try to deploy. We have tried with both new builds an old packages that has been successfully deployed before and all are getting the same error. (After 25 attempts the deploy is rolled back)
Thank you for any advice

Hi @cecilia,

Thank you for contacting Octopus Support. I’m sorry to hear you are running into issues with your Azure deployments.

Is it possible you are impacted by the Azure TLS depreciation? More info here: Deprecating weak cryptographic standards (TLS 1.0 and 1.1) in Azure DevOps Services - Azure DevOps Blog

Otherwise, if you could share a raw task log from your latest deployment attempt, I’m happy to have a look.

I look forward to hearing back from you.

Best Regards,

Just to make everyone that reads this aware @cecilia has kindly updated us on this issue over on our internal ticketing system so I will put her comment here to update everyone that comes across this error themselves:


Now it suddenly seems to be working again. I don’t think it had anything to do with TLS. I’ll let you know if it happens again.




She will follow up if it stops working again but for now this seems like an anomaly on her instance.

Kind Regards,

Clare Martin

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.