SemVer 2.0.0 support problem

I try to upload a semver 2.0.0 versioned package to octopus. When i do it via the UI i get an error page:

But the package is shown in the list with the hashcode but it is not possible to open its page, i gives me the same error page. Also i am not able to download the package, a 404 not found page is shown.

As i can remember i tried to play with SemVer 2.0.0 packages some month ago and back then i was able to upload and download those packages.

Is there a known bug in 2018.5.1 version? My example version was: 1.2.59+testhashcode.

Hi Attila,

Thanks for getting in touch! Unfortunately I haven’t been able to reproduce this behavior using this version (1.2.59+testhashcode, which is valid SemVer2). I’m packaging and pushing via Octo.exe, and also uploading via the UI and not hitting any error on upload or viewing the package. What’s the full package name you’re defining it as (i.e. ID and version combined)? How are you packaging it (Octo.exe, OctoPack, NuGet.exe, etc.)? I’ll be happy to try reproducing it using the same method. :slight_smile:

I look forward to hearing back and getting to the bottom of this one!

Kind regards,


Ok, i tried to reproduce it in the easiest way and i could. Here are my steps:

  • Visual Studio 2017 (15.7.1) -> Create new project -> Class Library (.NET Core). Project name: TestClassLibrary. Dotnet core SDK: 2.1.200
  • Build this project from command line: dotnet restore, dotnet msbuild
  • Create package from this project with command: dotnet msbuild /t:pack /p:PackageVersion=1.2.3+testhashcode
  • Upload it from Octopus UI (Library -> Packages -> Upload package

It gives me the same error page as above. The package is in the list:

But if i click on the exact version, i get:

Is this enough to reproduce the problem? If you need anything else please let me know.


Hi Attila,

Thanks for getting in touch and expanding on your scenario to help out. Unfortunately OctoPack isn’t compatible with ASP.NET Core applications, and we recommend using dotnet pack from Microsoft. You can reference Microsoft’s documentation for this command.

We also have a *Deploying ASP.NET Core Web Applications`doc page which may provide some additional details. :slight_smile:

I hope this helps get you going! Don’t hesitate to reach out if you have any further questions going forward.

Kind regards,


Hi Kenneth,

i don’t really get your point, how is this connected to my problem? I know how Octopus supports dotnet core project, we did a plenty of them recently. The problem is only occures if the version is a SemVer 2.0.0 version.

So if my above example is modified like this: dotnet msbuild /t:pack /p:PackageVersion=1.2.4. I can upload the package from the UI as expected. That’s why i suppose that the problem is connected to the SemVer 2.0.0 and not with dotnet core.

Can we go further to investigate this problem?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.