Schema integrity check failed

usability
#1

Hey @tina.bamford

Sorry i had to get back to you again… but this is just as a precaution.
While upgrading has been delayed because of other production issues and we did not want to take risk with deployment hence upgrading delayed.
My question is that as a precheck before upgrade I check for its system integrity and found the below error.

Could you please help me understand what’s causing this and that i would like to have this clean before getting on with the upgrade.

Happy to connect but sorry for trouble :slight_smile:

BR
Sharjil

(Kenneth Bates) #3

Hi Sharjil,

Thanks for getting in touch! I can help out Tina here for the time being. :slight_smile:

It looks like you have some custom indexes on your deployment table in the database that Octopus isn’t expecting, causing the schema check to fail. This probably isn’t anything to worry about prior to upgrading and the index will be removed and Octopus will attempt to re-add it during the upgrade itself. You could also remove that index from your database before the upgrade, which should mean the schema check passes.

I hope this helps! Let me know how you go or if you have any further questions moving forward.

Best regards,

Kenny

#4

Thank you @Kenneth_Bates
Just to give you a quick background though, i performed a test upgrade using the same database(however i do not remember noticing this schema check failure then) but after upgrading i do not get any system check failure. If Octopus does add it again then i should have got the same error when on a new version.
But i will want to find out when these index were added, is that possible ?

BR
Sharjil

#5

Hello @Kenneth_Bates

Happy to tell that the upgrade ran successfully !
But i do have one concern, the dashboard does not update with the latest deployed version for a particular environment.
This renders the dashboard useless since in order to check for the latest release we have to get inside the projects to check.
I googled, seems like a bug which was fixed.
Any idea how can i fix this after coming to version 2018.10.7

BR
Sharjil