S3 Deployment with Metadata

(Nicole Jeneka) #1


We are currently trialing Octopus and have a step to deploy S3. In that step we set metadata on a single file. The meta data is for Key: Cache-Control, Value: no-cache, no-store, max-age=0.

When deployed the meta data is set on the file but it is set with Key= x-amz-meta-cache-control which is user defined meta data

but we need to set the Cache-Control CacheControl

Is there a way to set Cache-Control metadata rather than x-amz-meta-cache-control?


(Shaun Marx) #5

Hi Nicole, thanks for getting in touch,

This is definitely an oversight on our behalf. I have created an issue which you can use to track progress. I believe using an AWS CLI script step may be a possible workaround in the interim albeit less than ideal.

I would like to apologize for any inconvenience this may have caused you and we will try and rectify this as soon as possible.


(Scott) #6

Sorry to resurrect this -
Has this issue been resolved? I see the Issue has been closed but am encountering similar issues with setting Content-Type on 2019.6.0

It would be nicer/cleaner to have this as all one step

(Nicole Jeneka) #7

Hi Scott,

Yes, this issue was resolved. We are using the hosted version 2019.5.12 and it seems to be working in that version.



1 Like