Runbook ignores "Default Failure Mode" option

“Default Failure Mode” for runbook is set to “Do not use guided failure mode”:
image

Runbook with these settings is published:
image

But it seems that published snapshot is still using guided failure mode from environment settings, but as I understand, runs should fail instead this, because of the option from the first screenshot:
image

It it bug, or did I misunderstood something?

Octopus Server v2020.3.4

Hi Rafal,

Thank you for contacting Octopus Support.

Did you publish a new snapshot after turning guided failure mode off? Is this happening for more than one runbook/project?

I look forward to hearing back from you.

Regards,
Donny

Yes, that’s exactly what I’ve wrote.

  • I’ve made changes
  • run draft (as this seems required in newset Octopus Server to Publish runbook snapshot, in older versions that wasn’t necessary)
  • published snapshot

And yes, this seems to be a problem for all runbooks.

Edit:
It seems that changing this setting doesn’t make new snapshot, but it should, I guess? It should force me to run new draft (as the settings were changed) and then publish it again?

Hi Rafal,

You are correct. Once you make the change, you will need to manually publish a new Snapshot. After you published the new Snapshot, did the Runbook behave as intended?

Best Regards,
Donny