Release package is missing from Octopus

#1

Hi Octopus support,

We were trying to redeploy a release that was created a couple of weeks ago to one environment and noticed the package was missing from Octopus. The Octopus version we are using is 3.17.14

We are using external team city NuGet feeds, and we can confirm that the package we would like to deploy is still in the feed and we can download the target version using NuGet Package manager without any issue.

Our retention policy for both octopus and team city is keeping the packages forever.

It seems that octopus is calling the api below to get the package from team city.

https://octopus server/api/feeds/feeds-team-city-builds/packages/notes?packageId=XXXX&version=YYYY

and it is returning 404 error. We can see that there is an error from team city server log saying
that the package Id XXXX with version YYYY is not found.

However, if we call team city NuGet feed API as below, we can get the package info without any issue.

http://team city server/httpAuth/app/nuget/v1/FeedService.svc/Packages(Id=‘XXXX’,Version=‘YYYY’)

I have tried to rebuild the team city NuGet feed index, but it does not work.

Another thing is that this does not seem to happen to every package.
It seems that it only happens when the same version of the package is built from two different team city projects, but I am not 100% sure. Even though it does not explain why we can find the package from team city NuGet feed directly, but Octopus can not…

Is that possible to know what function and parameters Octopus will call and pass to team city NuGet feed api?

Can someone please shed some lights on this?

Kind regards,
Jin

(Matt Richardson) #3

Hi there

Thanks for getting in touch!. Sorry to see you’re having issues with this.

Can you let me know what version of TeamCity you’re using? We’ve noticed in the past that JetBrains have had a few issues with nuget feeds, and upgrades have changed the behavior too, so we’ve had to implement fixes on our side a few times. One that might be relevant is https://github.com/OctopusDeploy/Issues/issues/4920, which was fixed in 2018.9.8.

What is the version number of the package? Is it semver2?

Have you tried setting the flag on the feed to use the extended api? Does that help?

Have you tried the latest version of Octopus? Is that able to find the package?

We use a custom fork of the nuget client to interact with the feed, which makes multiple calls. Once I understand your scenario a bit better, I can help figure out what api calls its making to the nuget feed.

Look forward to getting to the bottom of this.

Cheers,
Matt

(system) closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.