Release is missing

Hi All,

Using version: Octopus Deploy

I have a project which is set to automatic release creation based on internal repository upload.

I ran our normal build process which pushed a new nuget package. This would normally create a release for me in our project.

Upon looking at the release list I don’t see my release there. Strange I thought. Figured maybe I’ll try create it manually. Nope the number that the auto version number increment picks is already there, but strange when I look at the release list I don’t see it still.

I read the article about the RavenDB indexes always being a little funny so figured I’d try the Repair RavenDB storage option. Nope still not there.

Anyone know how I can get the website to show me the release?


Hi Rick,

Thanks for getting in touch! All I can think of here is cache. Weird weird cache. Can you try deleting your cache and also try viewing it in another browser?
You could also browse the RavenDB and confirm that it is there (from the Octopus Manager there is a link). If you could let me know the total number of releases that might also help.

This is a bit of a weird one.

Hi Vanessa,

Thanks for the reply. Not browser cache. What I have found is that my release versioning number has been screwed up.

I only have about 12 releases (got quite an aggressive retention policy).

My versioning went like this.

1.0.332, 1.0.336, 1.0.337, 1.0.341 (the ones in between have been removed due to the retention policy).

Then things went weird and I got a 1.0.10 and a 1.0.11 and then the troublesome 1.0.12 which never showed up. A few builds later and 1.0.13 appeared on the screen.

Then it went back to 1.0.10 and then 1.0.11 and 1.0.6 and 1.0.7 and then 1.0.8 and 1.0.9 and then wow. 1.0.12 again.

The versioning is all over the place for this project at the moment.

It all appears to be related to upgrades and it upsetting the versioning scheme.


Hi Rick,

Thanks for the reply. The release screen orders by date created, so you still should have been able to see the release. Hopefully I am understanding the situation correctly, but I might confirm anyway.
Are you defining and creating the release numbers yourself when you create the release, or relying on Octopus to do it?
Can you provide a screenshot of your Project Settings that defines the release version? It might be an idea to set it to match the package version.