Relative Path - Does Not Exist, IIS Step Template

(Lianne Crocker) #1

Hi,

I’m using the IIS step template in my project and it has been working fine. Recently I changed the step to use a Custom Folder using “Relative path under package installation directory” and I get an error saying the folder does not exist, how can I get it to create the folder if it does not exist?

Thanks.

(Lianne Crocker) #2

Hi,

Thanks for the question!

The “Relative path…” option under the IIS step configuration requires you to have a folder of that name within the package that has been selected to be deployed.

relative-path.png

If the package you are deploying does not have the folder inside it you can set a custom installation directory. To do this, first select “Configure Features”

Configure-features.png

Then select Custom Installation Directory

Configure-Custom-Install-Dir.png

Enter the directory name, this could be a set value or taken from a variable. Also, set the Physical Path to Package Installation Directory. Documentation on this can be found here: https://octopus.com/docs/deployment-process/configuration-features/custom-installation-directory

Custom-Install-Dir.png

If neither option covers the scenario you have you could add a script step to add the folder before the IIS step, or there is a Community step template that creates folders https://library.octopus.com/step-templates/b7211497-59ea-41e9-b466-c9a46b4c76b3

If you have any further questions please get in contact!

Thanks,