Problems connecting between an Azure Octo VM and Azure SQL DB using MSI installer


I could do with some guidance. I have a VM upon which I wish to install Octopus Server via the latest download. It is to connect to a Azure SQL DB which is on another Azure Subscription.

When I run the installer, I have a license file, I am installing in the default location, Local Host, correct SQL connections - it fails as it says that the SQL server is refusing the connection from the IP address of the VM. Yet when I use SQL manager on the same VM and apply the same SQL credentials I can remotely connect OK.

Any suggestions as to why the MSI installer cannot connect to the SQL server?

It’s a supported OS and SQL version and the latest installed downloaded today for a 64 bit machine.



i.e. the installer cannot get past the Database credentials screen.

Hi Tom,
Thanks for getting in touch! I’m sorry to hear you are seeing issues installing a new instance of Octopus server connecting to Azure SQL for the database.

To test this fully, I spun up a new Azure SQL database and a brand new Windows Server 2016 VM and attempted to set everything up. I was able to get this working successfully by performing the following steps.

  1. Create a new Azure SQL Database and server.
  2. Ensure the Allow access to Azure services is switched ON
  3. Checked the connection string of my new database form the Azure Portal
  • take note of the server it’s talking to: <yourdatabaseserver>,1433
  • take note of username and password
  • take note of the database name specified when creating it in the Portal.
  1. Login to the new Octopus Server VM and install the latest version of Octopus Server Manager.
  2. Proceed past the license, Home and Service Account pages. I set everything to the default settings.
  3. On the Database page Set these details
  • Server Name: <yourdatabaseserver>,1433
  • Authentication SQL Server authentication
  • Login <Username given when creating the Azure SQL Database>
  • Password <password given when creating the Azure SQL Database>
  • Database <yourdatabase>

This should be all that is needed to progress past this screen. The most critical points to note are to set the authentication to SQL Server Authentication and to ensure the Allow access to Azure services is switched ON

I look forward to hearing if this has helped, please let me know if you continue to see issues configuring the database.

Kind regards,


We have sorted it.

The issue is whilst we had given the below details and given Octopus the permissions to see the DB via the connection (on of thirty on the pool), Octopus also needs permissions to the Master Database to connect…

Job done …. Its operational.




One other question if I may, I need to covert my trial license to a paying license quite soon but I need advice as to what license number I need and I need a quote …

Can you point me in the right direction re name and contact details please.



Hi Tom,

Thanks for getting back to us! My name is Nicola and I’m from the sales team! Lawrence has asked me to reach out to you in regards to the license and quote.

At this stage we don’t have an upgrade path using your trial license to a paid license. A new license purchase is needed (if you are needing more than the Community Edition license limits). Our licenses are limited to Machines/Deployment Targets. At the current time, only deployment targets are counted for the purposes of licensing, but as we move forward with first-class support for Azure and AWS it is likely to include App Services and other things too. If you are able to let me know how many Machines you have currently I can send you back a quote or please feel free to look over our pricing by visiting our purchase page.

I hope this helps, please let me know if you have any questions

Thanks Nicola