Problem with the Step Template Parameter type "A previous deployment step name"

I created a step template that has a parameter with the Control Type “A previous deployment step name”. I added a step based on this template to my project and noticed that the drop down box does not expand although I have plenty of steps before this one. In the same project I have another step based on a template I created around 4-5 month ago. It worked fine at that time but now it also does not show a list of previous steps although the one I selected back then still shows.

I am on Octopus 3.7.4.


This just happened to me upon upgrading to 3.7.5 (previously on 3.4.11) and is a full on breaking change for us. The only workaround I was able to find is using the Bluefin “Edit step as JSON” and hardcoding the parameter in there.

Also, when opening steps that already have templates that use the “previous deployment step name” parameter type, the value is selected but I am unable to change it to anything else, as the dropdown does not expand.

This is a huge issue for us as we use step templates to run all of our scripts.

Hi Chris and Rosti,

Could you please both send us:

  1. The full JSON export of one of the step templates that are showing this error.
  2. A screenshot of your deployment process where I can see all the steps you have. Try to draw a circle around the step that’s using the template you sent on step (1).

Feel free to attach that info here if your templates don’t have any sensitive info (they usually don’t), or email everything at saying it belongs to this thread.


Actually, don’t mind my previous comment. I was able to reproduce this with a brand new step template created in 3.7.5. Raised a bug a get this fixed:

Thanks, Dalmiro!

Hi there,

Just wanted to let you know that we just shipped 3.7.6 with a fix for this.


Thank you! That was quick!

Dalmiro, thank you very much for the quick turnaround. Couldn’t be happier!

Credit goes to my friend Pawel who fixed it right away


I’ve upgraded to 3.7.6 and am still unable to select from the dropdown on the template. Is it required that I update the template? I’m hesitant to try it on my own, as I don’t want to risk breaking anything currently using it.

Scratch that. Apparently something may have been cached, as it started working about 15 minutes later. Sorry for the confusion!