Problem after upgrading to 3.3.6


I receive this message in my TeamCity build in the step “Create Package”, after upgrading Octopus:
Error reading string. Unexpected token: StartObject. Path ‘Steps[4].Actions[0].Properties.Octopus.Action.IISWebSite.ApplicationPoolPassword’, line 141, position 67.

I already updated the TeamCity Octopus plugin to version 3.3.1.

I get this error I guess because I’m using a step template called IIS AppPool - Delete:!/step-template/actiontemplate-iis-apppool-delete

So it looks like when it’s looking for the password parameter, there’s the problem:
IF (! $parameterName -contains “Password”)

But this step template doesn’t even accepts a Password as a parameter (only #{AppPoolName}).

So why I’m having this problem in TeamCity? In Octopus I could sucessfully create releases manually, that get the artifacts from the TeamCity Nuget feed…


Fixed it. In Teamcity had to change the drop down Octopus version: from 2.0+ to 3.0+

Hi Miguel,
Glad to hear you got your deployments working again. Drop us a line if you run into any further problems.
Happy deployments!


I had the same issues as well. I tried to copy the TC Plugin into the plugins folder after trying to not delete the previous Octo folder and then deleting the previous Octo folder. My Octo Plugin version was stuck. I ended up uploading the Octo zip through the TC Admin UI and restarted and that fixed it.

This was the only part of the upgrade from 2.6 that went poorly. Everything else was perfect.

Sorry, I’m actually still having the “Error reading string. Unexpected token: StartObject. Path ‘Steps[0].Actions[0].Properties.Octopus.Action.IISWebSite.ApplicationPoolPassword’,” issue.

It appears to have the correct Octopus version but not the correct command line tool. I check the buildagent temp folder and it is copying buildtmp/octo-temp/1.0 - 3.0 . Below is a snippet of the TC build log

[Octopus Deploy] Creating Octopus Deploy release
[17:45:43][Octopus Deploy] Octopus Deploy Command Line Tool, version
[17:45:43][Octopus Deploy]
[17:45:44][Octopus Deploy] Handshaking with Octopus server: http://####
[17:45:44][Octopus Deploy] Handshake successful. Octopus version: 3.3.20; API version: 3.0.0

I figured out what was going on. The build step for runner type OctopusDeploy: Create Release needs for the Octopus Version: to be changed to 3.0+