Powerscript is producing specific error consistently - unexpected token

Whether I try to run PS (embedded script) as a specific step, or whether I call out to run a PS script on a Tentacle server (i.e. a call to C:\test.ps1 as the PS code), I am consistently receiving the following error:

Unexpected token ‘:’ in expression or statement.
Error 10:23:33
At C:\Documents and Settings\Default User.WINNT\Local Settings\Application Data
Error 10:23:33
\Tentacle\Temp\Bootstrap.5a601bc3-65de-462a-9de9-3b550466de35.ps1:506 char:8
Error 10:23:33

  • “Id”: <<<< “ActionTemplates-1”,
    Error 10:23:33
    • CategoryInfo : ParserError: (::String) [], ParseException
      Error 10:23:33
    • FullyQualifiedErrorId : UnexpectedToken
      Info 10:23:33
      PowerShell exit code: 0
      Warning 10:23:33
      The script returned an exit code of 0, but output was written to the error output stream. Please investigate any errors in the script output above.


  • The tentacle server is running Windows Server 2003 R2, Service Pack 2.
  • I tried this on another server, running Server 2003 Service Pack 2, and received the same error.
  • Powershell is installed on the target servers. I am not certain of which version(s) are installed, though. It does satisy the requirement of the Tentacle server though, because the Tentacle is running without issues it seems.
  • A NuGet package does install successfully on this server. No Powerscript is involved in the process step.
  • The Octopus server is running Server 2008 R2.

Please advise what suggestions you may have, or if you have further questions.

I seem to have resolved this.

We had a script module or two, included in the project, and didn’t realize they were actually being used.

I removed them for now, and the error no longer exists.
Tricky to troubleshoot!