Package extraction timestamps and time zones

Up until recently, our servers have all been in the same time zone, Central. Now that we’re shifting workloads to Azure, our servers there are in UTC instead.

I’ve noticed that this means the extracted files from packages show up with incorrect timestamps. A file built at 12:22 PM Central (UTC + 6) gets extracted to the server with a timestamp of 12:22 PM UTC instead. This makes diagnosing if files were deployed correctly difficult.

Is there anything we can do to make it so that the Tentacle extracts packages with the correct timestamp?

These packages are NuGet packages built by the Package Applications for Octopus task for Azure DevOps, version 4.1.440.

Hi Andrew,

Thanks for reaching out to us at Octopus Support! I’m sorry you’re running into this issue.

This does seem like odd behavior, so I’d like to look further into it. Could you confirm the timezone that your build server is currently set to?

Since timestamps aren’t timezone aware, you’d likely want to coordinate your configured timezone across your deployment pipeline. Using a post-deployment script to adjust the timestamp on the file to the appropriate timezone could be an option as well.

Thanks,
Mallory

The build servers are in Central too.

Hi Andrew,

Thanks for your quick reply!

The more I probed into the issue, the more it started to make sense. I see now that what’s happening is that the ZIP file is preserving the timestamp on the files, but then once they land on the Azure server, it’s giving it a timezone consistent with their settings.

To avoid fiddling with conversions, a couple of the best options would be to set your whole pipeline to utilize UTC or to use a post-deployment script to adjust the file’s timestamp.

Please let me know if you have any questions!

Thanks,
Mallory