Octopus will not add the custom account specified during install

Hi all,
I am attempting to set up an install of OctopusDeploy latest release on a Windows server 2019 server. I have discovered that when getting to the service account tab, I can use a custom domain account, but the next screen will then not allow me to use that same account to connect to SQL server. We have two different SQL server machines in the network, and for some reason, I have had to manually override the available SQL server options while running the install; since Octopus keeps pointing to our other server, which isn’t the correct one. I can, however, get past the database screen when using the default system account as the service account to connect, which isn’t what we want. I can use the Octodeploy account when connecting to SSMS using the run as different user option from my local workstation. Suggestions? Thanks.

Not sure whether or not this matters, but the SQL server is on version 2017.

Hi Katherine,

I’ve been discussing this with the customer success team and we think that the issues you’re hitting might be caused by the Database tab on the installer using your user account to fetch the database information instead of the account you configured on the Service Account tab.

It will use the service account once it’s installed through Windows Authentication.

Are both database servers available from the Server Name drop down on the Database tab? If not, do both have SQL Server Browser Service turned on? And does your user account have access to both servers?

When your overriding the options, is that through the fields on the tab or by using the Advanced… options dialog?

A screen share showing the process would help a ton. If you’re able to do that, can you email advice@octopus.com and we’ll set one up?


1 Like

My user account does not have access to the SQL server that I am attempting to have Octopus connect to. If it needs it, then, I can request it. I can, however, use the account for Octopus to connect to the server from my local workstation. I can do a screen share if you are comfortable with the Zoom meetings software; that’s easy, though you are going to have to put up with the fact that I am not visual at all; legally blind, so everything I see is through auditory inputs from screen readers. In order to find the SQL server I need, I have to select advanced, and then physically type in the server’s name. I can’t select it via the combo box for some reason. Not sure if that’s my doing or if it seriously isn’t showing for some weird reason.

Thanks for the info. Your user account not having access to the database is what’s preventing the server from showing up in the drop down. You should still be able to configure it manually through the advanced section. If that’s not working, I’d like to see what’s happening so that I can understand it better. I sent a reply to your advice email with a link where we can set up a Zoom meeting.

Once I add my account to the SQL Server, then, will the instance configurator know to use the specified domain account I picked for the service as the one running the database, as well? There is no place that I can see in order to enter
a connection string.

Yes indeed. If you use the Windows Authentication mode for the database, it’ll use the account the service is running as. This is represented as the “Integrated Security=True” portion of the connection string.

Ah … I remembered that, however, that’s awesome how invisible it is in the case of Octopus. I never would have had that make sense if you hadn’t explained it. Looks like I need to read up on SQL server basics. I will keep you guys updated
on how it goes. I can’t wait, because this will make development processes so much easier.

Glad to help!