Octopus v2019.3.2 LTS - Cannot read property 'split' of undefined

(Alex) #1

Hi Octopus Support,

We just upgraded to Octopus v2019.3.2 LTS version, and we are getting the same error editing volumes.

Do you have any recommendations at this point for resolution now that we are on a supported version?

Original post: When using the Deploy Kubernetes step in our projects, we can edit all of the options except “Add Volume.” When selecting Add Volume, we receive the below error. The only workaround is to completely remove the step and re-add it, even if all we want to do is add another volume.

An unexpected error occurred in Octopus v2019.3.2: Cannot read property ‘split’ of undefined

TypeError: Cannot read property ‘split’ of undefined
n. (https://octopustest.wanlink.us/main.259976b1512254c5e2e5.hashedasset.js:1:5068697)
https://octopustest.wanlink.us/main.259976b1512254c5e2e5.hashedasset.js:1:5066245
Object.next (https://octopustest.wanlink.us/main.259976b1512254c5e2e5.hashedasset.js:1:5066350)
s (https://octopustest.wanlink.us/main.259976b1512254c5e2e5.hashedasset.js:1:5065096)
https://octopustest.wanlink.us/vendor.162da54cfd8cb21a5b6e.hashedasset.js:70:2822
z (https://octopustest.wanlink.us/vendor.162da54cfd8cb21a5b6e.hashedasset.js:70:2856)
N (https://octopustest.wanlink.us/vendor.162da54cfd8cb21a5b6e.hashedasset.js:70:2636)
MutationObserver.g (https://octopustest.wanlink.us/vendor.162da54cfd8cb21a5b6e.hashedasset.js:70:671)

(Kenneth Bates) #3

Hi Alex,

Thanks for getting in touch! I’m terribly sorry to hear you’re hitting this confusing and annoying issue. Unfortunately I haven’t had any luck in reproducing this, so we’re currently unsure of how this could have happened. We’ve seen the same error in the past in regards to other step types, however.

Would you be willing to send us through a JSON export of your deployment process (this can be downloaded in your project’s Process page, under the overflow menu)? I’m hoping this sheds some light on what’s causing this. You can send it privately to support at octopus dot com and we’ll pick it up from there.

I’m sorry again about the inconvenience this has caused you, and I look forward to hearing back!

Best regards,

Kenny

(Alex) #4

Hi Kenneth,

I emailed the support email with the JSON. Thanks!

(Kenneth Bates) #5

Hi Alex,

Thank you kindly for providing that JSON export. It really helped me out in finally reproducing this behavior. The way I was able to do this was by disabling the features from the step before attempting to add a volume. It looks like in your JSON export, no additional features are enabled in the step, but the volume’s type is set to Config Map.

The only way I’ve been able to work around this (other than recreating the step from scratch) is to enable the default features of the step (Service, Ingress, Config Map, and Secret), saving, and then the new volume popup comes up properly. I’ve raised this issue to get it investigated further and resolved, and you can track its progress here.

I appreciate you bringing this to our attention, and I’m sorry again about the inconvenience this has caused. Please don’t hesitate to reach out if you have any further questions or concerns moving forward. :slight_smile:

Best regards,

Kenny

1 Like
(Alex) #6

Thank you Kenny! I really appreciate you looking into this. We will keep track of this issue.

(Kenneth Bates) #7

Hi Alex,

Thanks for following up, and you’re more than welcome! Don’t hesitate to reach out if you have any questions or concerns in the future. :slight_smile:

Best regards,

Kenny