Octopus Error while Import


(Vinod Deo) #1

HI Team ,

I am trying to Import all Octopus server stuff from one of the DEV server to UAT server , facing below issue-

Can you please assist on the same

Regards,
Vinod Deo


#3

Hi @vinod.ramesh.deo,

Thanks for getting in touch, and sorry to see that you ran into a problem migrating data.

Firstly, are you able to let me know how you are migrating data from one Octopus Server to another, and that both servers are the same version of Octopus?

If you are using Octopus.Migrator we have been doing a lot of work recently on improving this experience, so are you able to let me know which version of Octopus you are currently running so I can check if this issue has been resolved in a newer version?

Thanks Vinod, hopefully we get get this sorted for you quickly.

Regards,
Alex


(Vinod Deo) #4

Thanks Alex for your reply on this . We are using Octopus Version 3.16.7 on both the Source server and Target server somehow we need this version only for our Import task.

We are using the Import - Export functionality of the octopus manager , where we have exported Json files from our DEV server to UAT server. Although the Project groups are getting imported , it is not showing under Configurations >> Teams.

Regards,
Vinod Deo


(Michael Noonan) #5

Hi Vinod,

@Alex.Rolley is right. This problem should be resolved by upgrading both the source and target servers to the latest available version of Octopus Server, and then export + import the data again.

As far as upgrading, I would recommend 2018.10 LTS where we have fixed all of the migrator problems we could find as we worked with several customers doing complex data migration.

You can see a list of these problems in case it’s helpful: https://github.com/OctopusDeploy/Issues/issues?utf8=✓&q=+is%3Aissue+label%3Afeature%2Fmigrator+

Hope that helps!
Mike