Octopus deploy for Jira app not installing

(Arie) #1

Hi support,

We are using Octopus deploy in our Company and want to integrate JIRA with octopus. However when installing it runs into an error and the app is not installed. The reply from JIRA support is redirecting me to you an dI hope you can help.

Below is the mail with more details from JIRA support.

Thanks in advance
Arie

Hi Arie,

Thank you for contacting Atlassian Support.

With regards to the issue that you have raised, I was able to reproduce the issue while trying to install Octopus Deploy plugin for Jira and found below error

com.atlassian.plugin.connect.plugin.lifecycle.ConnectAddonInstallRejectedException: Error contacting remote application 400:[Bad Request]:

at com.atlassian.plugin.connect.plugin.lifecycle.ConnectAddonCallbackHandler.requestInstallCallback(ConnectAddonCallbackHandler.java:154)

at com.atlassian.plugin.connect.plugin.lifecycle.ConnectAddonCallbackHandler.requestInstallCallback(ConnectAddonCallbackHandler.java:96)

at com.atlassian.plugin.connect.plugin.lifecycle.ConnectAddonManager.makeSyncCallbackIfRequired(ConnectAddonManager.java:486)

at com.atlassian.plugin.connect.plugin.lifecycle.ConnectAddonManager.installConnectAddon(ConnectAddonManager.java:175)

at com.atlassian.plugin.connect.plugin.lifecycle.ConnectAddonInstaller.install(ConnectAddonInstaller.java:226)

Error contacting remote application at ‘https://jiraconnectapp.octopus.com/jira/events/installed?user_key=557057%3A6817257c-76c2-4e46-8ffb-97c37540e354&user_account_id=557057%3A6817257c-76c2-4e46-8ffb-97c37540e354’ 400:[Bad Request]:

I did another test by installing a different addon ScriptRunner for Jira and the addon was installed successfully(I’ve removed it as it just for testing purposes)

Based on my test and the error from the logs, I suggest you contact the addon vendor directly as it seems the issue is from their end. You can raise a support ticket to the directly from here:

Hope that helps.

Regards,
Azmir.Zan

(Henrik Andersson) #3

Hi Azmir,

I just tried to install the Octopus plugin into my own Jira Cloud instance and it succeeded for me.

Can you try to install the Octopus plugin from the Atlassian marketplace again and see if it works for you now?

Thank you and best regards,
Henrik

(Arie) #4

Hi Henrik,

Azmir from atlassian gave me those logs in my previous post. I just tried to install again and still the same error, the app is not installing.

Can you help me out here?

Thanks in advance!
Arie

(Henrik Andersson) #5

Hi Arie,

I’ve made some changes, can you please try it again now.

Thank you and best regards,
Henrik

(Arie) #6

Hi Henrik,

It’s installing now, thanks for the quick support :slight_smile:

Best regards,
Arie

(Henrik Andersson) #7

Hi Arie,

Great to hear that you were able to install the plugin now.

Thanks for letting me know.

Cheers,
Henrik

(Daniel Snyder) #8

Henrik,

I am also having issues setting up the Jira integration. I have installed the application in Jira multiple times and performed the get started process, but it always returns to a get started stage or uninstall. Any help would be appreciated. Thanks

-Dan