Octopus Deploy connection

I’m installing Octopus for the first time, and having trouble getting my Octopus Server talking to my Tentacle.
Octopus Version 3.2.23

Upon the health check of my Tentacle, I continually receive the failed connection error because the connection host failed to respond.
After some digging, it’s very clear my Octopus Server is making a call to the Tentacle, but the Tentacle never sees the request, as if it’s not listening on the default port 10933 at all.

Here’s additional information per my troubleshooting so far:

  • Both servers are in the same network, in Amazon, with no proxy in between.
  • The AWS security group allows inbound/outbound traffic over 10933
  • Windows firewall is turned Off on both the source/destination machines.
  • On the Tentacle itself, in a web browser I can see the ‘configured successfully’ screen.
  • The thumbprint of the Tentacle matches what I input on the Deploy Server when I went to Add a new Tentacle.

Any idea as to what am I missing? Even one of our best network security guys is convinced this is an application problem…



Does port 443 need to be open between the Deploy Server and tentacle as well? I don’t believe we have that opened up currently…

Hi Evan,
I’m sorry you are having such problems trying to get your Octopus server and Tentacle up and running successfully. Unless you are setting up your Tentacle through some sort of automated script you shouldn’t have a need to open 443 between the Tentacle and Server. This port is sometimes opened if the users want to run the register-with command on the Tentacle and have it register itself with the Server as seen in these scrips. We have further documentation page covering communication problems however it sounds as though you have already started crossing things off which is a good start.

You note that you are able to see the configured successfully screen on the Tentacle server itself. Are you able to see this from the Octopus Server machine? If you can see that page we can confirm that the correct ports are open, if not then we know that the server will have no chance to even start the connection. For listening tentacles (which I assume that yours is) then indeed port 10933 needs to be open for them to communicate. Can you open a command prompt from the server and call the other tentacle machine via the command (substituting the correct host address):

telnet tentacleserver 10933
If it connects successfully you should get a blank console as it awaits further input (you can close it at this point).
As noted in the documentation, if this fails with both the Tentacle’s IP and DNS host name (but works locally) then perhaps there is a networking problem afoot. We have a simple networking utility for testing the communications protocol between two servers called TentaclePing. This consists of 2 parts, 'TentaclePing.exewhich runs on the OctopusServer side, andTentaclePong` which runs on the tentacle server. This is a very simple call and reply tool to confirm that the 2 machines can indeed talk to each other over a selected port.

If you can see the Tentacle’s “Hello” message in the browser from the Server, then it should have no other real barriers to connect and perhaps something in the logs will provide us with more information. Could you please send through the ServerTask and Tentacle logs, typically found in C:\Octopus\TaskLogs and C:\Octopus\Logs respectively.

I hope we can get your connectivity problems sorted soon and get the deployments running.


Hi Rob,

Thank you for your assistance.

Per the Tentacle Ping testing application, I’ve determined that the Tentacle application port 10933 was not listening, even though the Tentacle was configured correctly.
I worked with our networking team and they were able to open the port in a different way than they initially tried…I now seem to have communication between the Deploy Server and our Tentacle.

Thanks again!

From: Rob Erez [mailto:tender2+d1d516adbd@tenderapp.com]
Sent: Tuesday, February 23, 2016 12:01 AM
To: Hoffman, Evan Evan.Hoffman@invista.com
Subject: Re: Octopus Deploy connection [Problems #44596]

Sent by an external sender

Hi Evan,
Great to hear that you are up and working again. I know networking can be a pain, even in these days of everything in the cloud, there are still these networking puzzles we get ourselves into. Thanks for letting us know that its sorted.
Let me know if you run into any further problems with your setup.