Octopus Console Application Deployment Issue

execution

(Jagruti) #1

Hi,
I am trying to deploy the console application through octopus, and start the service through powershell script.I was able to do so but now the same thing is not working when I am deploying it to another server.What might be causing the issue?

Is there any other way to deploy console .Net Core application and start that instance on remote server through octopus?

Thanks in Advance for any help


(Kenneth Bates) #3

Hi Jagruti,

Thanks for getting in touch! I’m sorry to hear you’re hitting this roadblock. Strange it works on one server but not the other. Under which account is the Tentacle service running on that machine? Could you try temporarily running it under a different user?

If that doesn’t help, could you provide the full exported task log from this deployment, as outlined in the following doc page? Hopefully that’d give us more context to help troubleshooting. :slight_smile:

I look forward to hearing back!

Best regards,

Kenny


(Jagruti) #4

Thanks for your help, I will try this and will get back to you.


(Jagruti) #5

Hi Kenneth_Bates,
I tried the solution you suggested, It is working for me but what would be the permanent solution for this?

I have one more query, I am starting the service from Post Deploy (In Deploy Package step)script by using Start-Process command.I am not understanding how I can stop the currently running instance of same service through script.

I tried many options for this but no luck.please help if you have any idea about this.

Thank You


(system) #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.