Octopus cloud slowness

Over the last couple of weeks users have been complaining that our Octopus cloud instance has become noticeably slower.

To the point of deployments timing out today.

You can really see how slow things are as soon as you hit the Deploy button and wait and wait and wait and wait until the deployment screen shows.

Hi @Phil.Evans,

Thanks for reaching out and letting us know you’re experiencing performance issues with Octopus Cloud.

I have a few questions to ask if you don’t mind:
Is there a rough estimate for when your users started noticing Octopus being slow?
Has anything changed recently in the way you use Octopus?
Would you mind if I created a support user on your instance so that I can investigate further?
Is there a particular project(s) that experience this issue or would you say all of them?

Hopefully, we can help get to the bottom of what’s going on and resolve the issues you’re experiencing.

Kind Regards,
Adam

Hi Adam,

I think the slowness reports started coming in two weeks ago. I’ve asked members of my team for anything more specific than that.

I’m being told “Octopus is running like a slug at the moment” on a Teams chat. Time = 17/6/22 12:20pm NZT.

Nothing has changed in the way we use Octopus.

I would be happy for you to create a support user and investigate further.

This seems to be systemwide… across all spaces.

Kind regards,
Phil

Hi Phil,

Just stepping in for Adam while he’s offline.

I investigated your cloud instance’s performance yesterday for a request from Joseph Locke regarding the .NET timeouts on package upload. I couldn’t see any metrics that would indicate there’s a bottleneck and Joseph later mentioned the timeouts seem to have resolved themselves.

I’ll jump into your instance and have a look to see if I can spot any slow behaviour myself and will take a HAR file so we can try narrow down which endpoint is responsible and hopefully get to the bottom of this. Feel free to send through any HAR files of the slow behaviour you witness! (You can upload files securely here)

I’ll keep you posted with any updates or findings, let me know if you have any questions at all!

Best Regards,

Hi Phil,

Just an update - I was able to find evidence of some slow behaviour from your instance without logging in and have raised this with the engineers. It seems that it’s the ServerTask endpoint that is responsible for the slowness and they are aware of the issue and working on a fix asap.

The build with the fix should be applied to your instance during the next upgrade window but I’ll let you know here as soon as I have any updates about it also.

I’m really sorry for the frustration this is no doubt causing your team, thanks again for letting us know about it. Please feel free to let me know if you have any questions in the meantime!

Best Regards,

Hi Phil,

Just updating that a public GH issue has now been created for this issue: Slow Performance & Timeouts - ServerTasks/details endpoint · Issue #7611 · OctopusDeploy/Issues · GitHub

Unfortunately we haven’t identified a workaround yet but it is being treated with the highest priority.

Let me know if you have any questions or I can provide any further info!

Best Regards,

Hi Finnian,

Thanks for getting onto this for us so quickly. Really appreciated.

I’ll forward the info to our teams.

Kind regards,

Phil

1 Like