Octopus Cli: octo push hangs while pushing to a cloud instance.=

When I attempt to push a zip file to my Octopus Cloud Instance’s built-in feed, the command hangs indefinitely. I’ve had this deployment pipeline set up and working for some time, so it feels like there is something wrong with my cloud instance that’s preventing the upload.

Here is the command I am running:
octo push --package=MyPackage.1.0.51.zip --server https://pxegroup.octopus.app --apiKey ****

Here is the version information:
Octopus CLI, version 7.4.3576
Octopus Server, version v2021.3 (Build 8275)

Some things I’ve tried to troubleshoot:

  • Regenerating my API key. Had no effect. Still hangs.
  • Hitting the Octopus REST API to ensure that there is connectivity. I am able to successfully execute REST API calls against my cloud instance.

Is there a way to reboot a cloud instance?

Hi @rscaduto,

Thanks for getting in touch! That is a strange issue, I’m sorry for the inconvenience you’re hitting.

I ran through a test pushing a zip to a cloud instance with matching versions, and the push was successful. Your instance looks fine and healthy from what I can tell, with plenty of disk space, so it does seem a bit odd. Could I ask a couple additional clarifying questions?

What’s the size of this zip you’re trying to push?
Does this push command ever time out?
Can you get any additional helpful details by adding in --logLevel=Verbose into your push command?

If you’re currently stuck, you could try running the following REST script to push the package to your instance (or in the web portal directly under Library > Packages).

I look forward to hearing back and getting to the bottom of it!

Best regards,

Kenny

Hi Kenny,

Thanks for the reply. Long story short I rebooted the server and it started working again.

Not sure what the cause was, but as long as it’s working I’ll take it.

Thanks again!

-Rob

Hi Rob,

That’s great news, thanks for the update. Let us know if you have any questions or concerns at all in the future. :slight_smile:

Best regards,

Kenny