Octopack now putting content into bin\

Since an upgrade from 3.3.3 to 3.3.4 it seems that octopack is now putting the content into a “bin” sub folder in the package
is there a way to revert to the previous functionality?
or be able to have it install to the root of a custom install directory rather than the \bin

Hi Adam,

OctoPack is separate from Octopus Server, and is included in your project via NuGet. It is currently on version 3.0.60, and if you are having troubles with that you can try installing the previous version you where using. If that resolves the issue, let me know and we’ll look into why.

Also check to make sure that there have been no changes to the project’s nuspec file.

If you mean the pack command in Octo.exe, could you send me the command line you are using to invoke it? Also are you building NuGet packages or zips? Is it a web project or console/desktop?


Robert W

Thanks for the reply Robert,
we are currently allowing octopack to generate the nuspec file during the teamcity build using the octopus plugin

Octopack 3.0.60 and 3.0.59 have been tried (we upgraded from 59 thinking that may be the issue)

building Nuget Packages of a framework 4.5 console application
the nuspec being generated by octopack is prefixing the targets with the bin\

I have attached the nuspec that octopack is generating for the project, we are having this issue on multiple console application projects

Digging further into the log from the build we are seeing this line
[CreateOctoPackPackage] OctoPack: Add binary files to the bin folder
[CreateOctoPackPackage] OctoPack: Added file: bin\SiteMaintenance.exe.config

previous successful builds the output at the same place was
[CreateOctoPackPackage] OctoPack: Add binary files
[CreateOctoPackPackage] OctoPack: Added file: SiteMaintenance.exe.config

What would Octopack be seeing in the project output that would make it decide to place the files in the sub directory within the package?

SiteMaintenance.nuspec (2 KB)

Hi Adam,

Thank you for that extra information. I’m still not sure what could be causing it, but I am looking into it. Normally it switches behaviour based on the presence of a web.config file, but that does not seem to be the case.

In the meantime, could you send me some more of the incorrect build’s log output, particularly the lines just before and after the ones you sent relating to OctoPack?

Have you recently upgraded the OctoPack version? If so which one where you using previously?

Robert W

Hi Robert,

After having a dig in the OctoPack code on github we came to the same conclusion, checking our source however there was no web.config in there but as part of the build however it appears that Entity framework is generating a blank web.config file which is making octopack believe that it is a Web Application

That web.config is not part of the output only of the source (guessing during nuget package restore)

The only solution we can come up with is to create a nuspec file for octopack to use or do you have another suggestion for us?

Hi Adam,

Thanks for the info. Is the web.config being created in the root of the project or a subfolder? Also what version of EntityFramework? If I can reproduce it, and it’s likely to be a problem going forward, I can work on getting a patch out for OctoPack.

In the meantime, other than downgrading the EF package that caused the problem, creating a nuspec file is the best solution.

Robert W

the web.config is being generated at the project root along side the project file & other files (its an incredibly small solution)

version 6.0.0 of entity framework is being used.

We have just updated the project to the latest Entity framework 6 (6.1.3) and it appears the issue has now been resolved

Hi Adam,

Thanks for the update, I’m glad you got it sorted.

Robert W