Object reference not set to an instance of an object


(ge.bai) #1

We just upgraded our Octopus to v2019.1.9

Now we have a lot of users seeing error “Object reference not set to an instance of an object.”

In server log, we see
2019-02-27 09:38:56.3741 10900 19 ERROR Unhandled error on request: https://octopusdeploy/api/Spaces-1/projects/all 00bb6647dd4b413d8a6749d8db3befb0 by test : Object reference not set to an instance of an object.
System.NullReferenceException: Object reference not set to an instance of an object.

The site become un-useable now, could you please help?

Thanks,

Ge


(ge.bai) #2

We found a workaround - scope the project groups for Everyone team to “All Projects”. Although “All Projects” group is an empty group.

If we don’t specify any scope in Everyone team, users see those “not set to an instance of an object” error.

Is this by design or a bug?


(ge.bai) #3

Users see those errors when clicking Projects, Library, Tasks, and Configuration.


(ge.bai) #4

Same problem with Tasks view.

I ended up have to create a empty environment and scope Everyone team to that empty environment. So users can view tasks in their environment.


(John Simons) #6

Hi Ge,

I am very sorry that you are going through all this pain, this definitely does not sound right.

Are you able to provide me with the logs of the server, the easiest way is to go to Configuration > Diagnostics


and then send us the zip file.

Regards
John


(ge.bai) #7

Hi John,

The file cannot be uploaded due to the size.

Can I email you the zip file?

Thanks,

Ge


(Gudmundur Magnusson) #8

We are having the exact same issue with multiple users, would like to see a solution to this.


(John Simons) #9

Hi Ge,

Can you please upload your file to https://file.ac/ubntnl6aDpo/

Regards
John


(John Simons) #10

Hi GudmundurMagnusson

You can also upload you diagnostics file to https://file.ac/ubntnl6aDpo/

Regards
John


(ge.bai) #11

I can’t. Our company blocks file upload.

Are there any other options?


(John Simons) #12

Hi Ge,

Can you please email it to john.simons(at)octopus.com

Regards
John


(John Simons) #13

Hi Ge,

If the zip is still too large, just send us the log files zipped.

Regards
John


(ge.bai) #14

Sent.

Thanks!


(John Simons) #15

Hi Ge,

Thanks a lot for the logs.

I am still trying to figure out how to reproduce this issue, would you be able to send me a permissions export for the user that is/was getting these errors?
To export the permissions go to Configuration > Test Permissions and then select the user you were using and space and finally click the “Export User Permissions” button. This should download a file that contains all the permissions for this user. If you can attach that file would be great.

Regards
John


(John Simons) #16

Hi Ge,

I was able to reproduce the issue successfully.

I ended up raising this issue.

Once we fix this issue, you should be able to revert that changes you did to Everyone team.

Regards
John


(ge.bai) #17

Thanks for your help!