Null SQUID value


Can you help troubleshoot the following problem please:

I am setting up an additional listening tentacle using an Octopus Deploy server which I know has been correctly set up. When trying to discover the tentacle and add it to my environment, I am getting an error.

In the log file for the tentacle, I see the following message:
2014-02-03 14:01:33.6406 WARN Configured to listen to server {“Thumbprint”:“B71837ECA2DEEB3B1809FF8363FE97560F718055”,“CommunicationStyle”:0,“Address”:null,“Squid”:null}, but no SQUID is configured for it; skipping.

Looking at the config file tag, the SQUID is indeed null:

I have tried removing and reinstalling the tentacle. I have also tried deleting the config file before reinstalling it in order to regenerate it. The Squid is always equal to null.

Is there a file on the machine where the Squid is stored which I can delete in order to regenerate it correctly?
Is there another work around here which I am missing?

thank you

Hi Jennifer,

Thanks for the detailed info. When you add the machine, are you using the “Discover” feature, or entering details manually into the Octopus server?

If the machine is added manually, go to Environments > (Machine) > Connectivity; on this page there will be information about the machine’s communication status.

There’s also a button on this page “Reset” that can be used to re-start the handshaking process from the Octopus, useful in some of these situations. When you invoke it you may see the connection drop out temporarily while the Tentacle service on the remote machine restarts with the new configuration.

I think you’ve probably exhausted most of the suggestions on it already, but there may be some more clues at:

Can you also please let me know which version of Octopus and Tentacle you’re using, and how the Tentacle was initially set up? (E.g. did you clone a VM?)


Hi Nick-

Thank you for your prompt reply. Apparently, reinstalling the Octopus Service, in addition to reinstalling the Octopus Tentacle client, has generated the squid and solved my problem. Do you need me to close the discussion issue on the site?


Thanks for the follow-up, glad it is working. Nothing else needed - thanks! Nick