NuGet feed suddenly unauthorized

integration

(Tijs) #1

I am adding a NuGet feed that is hosted on our visualstudio.com account. The url that I’m adding looks like this:

https://***.pkgs.visualstudio.com/_packaging/***/nuget/v3/index.json

However, when I test this feed I get an 401 unauthorized error:

Package feed returned 401 Unauthorised, check the username and password for this feed. Also attempt to connect using NuGet.exe.

When I visit this url in incognito mode and enter the exact same credentials used when adding the feed it works correctly.

Also this has worked before so I do not understand why it is suddenly not working anymore…

Tested on v2018.2.6 (vm) and v2018.6.9 (cloud)


(Tijs) #2

Okay I’m sorry - the problem was on our side.


(Dalmiro Grañas) #3

Hi there,

I’m glad to hear you found a solution :).

Is there any chance you can tell us what fixed it for you? We had another report of a similar issue within the same day you posted this, and I’m wondering if there’s a patter here that we should be aware of.

Best regards,
Dalmiro


(Tijs) #4

In short: the Personal Access Token had expired.

To connect to the visualstudio.com nuget feed Octopus asks for credentials (email / password). When we got the 401 we just entered the credentials matching the one of the e-mail address that was already configured, assuming that user had changed his password. This did not work.

What we had forgotten is that instead of the user’s credentials you must use a Personal Access Token. Maybe some extra help text could be added in Octopus?


(system) #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.