Method not found

So, having the same issue as this guy: but uninstalling the library from the GAC isn’t really a solution. For one, I can’t uninstall the library since something else is using it and secondly, I don’t know what is using it - I don’t want to break something else.

Any other solutions? He closed his ticket a little prematurely …

(Same environment, just update to and can’t update the tentacles because of this)

Hi Kori,

Thanks for letting us know. I don’t think there’s very much that we can actually do about this - the whole point of the GAC is to be able to override local assemblies with what’s in the GAC. In the next release we’ll try a few options to see if we can specifically load our version, but there’s no guarantee it will work. Here’s an issue to track it:


Weird. I haven’t installed anything on this server in quite some time, it’s mostly used to house OD Server. Since this error message shows up everytime I go to update all tentacles, can I just update them manually?

Sent from my iPhone

Actually, this stops my entire OD from working. I can’t upgrade tenticles,
I can’t add machines to environments, I can’t deploy. I’m pretty much dead
in the water using

Kori Francis
Lead Software Developer
Clinical Support Systems, Inc.

Updated to, still no change. Can’t deploy, can’t upgrade. Stuck.

Alright, I’ve also worked around the issue by finding the app that installed Newtonsoft.Json.dll in the GAC and uninstalled the app (to uninstall it from the GAC). On my server, gacutil.exe didn’t exist and I couldn’t get any install of the Windows SDK to work - thinking it might help me find which app had it installed. Took me forever to find the app the long way around (uninstall all the things!).

Anyways, the issue does still exist - as ugly as it sounds, you might want to look at forcing use of the local assembly first before the GAC is searched.